« Where the hell is Matt | Main | DOA Live Action Movie »

CIA / 3web / Cybersurf Customer Service SUCKS

My Review of CIA / 3web / Cybersurf

ciasucks.jpg

What others have to say about CIA / 3web / Cybersurf

So I have a friend that was on 3web and said the internet service was fine, since it's really just Shaw, so I decided to try it since I was on Shaw anyway, and since I didn't have a land line, I may as well switch to them since it's the same price.

Here's a timeline of events:

May 28, 2006 - submitted my order for the service online, i was a Shaw internet only subscriber at the time. Since I own a cable modem only, i just need the voice terminal for the phone service.

June 6, 2006 - Recieved an email telling me my application was recieved.

June 29, 2006 - Got an email telling me my service is now active - this is just over 1 month from my original sign up date. I have not recieved a voice terminal at this point yet. I call they tell me they are back ordered, I should receive in a week.

Approximately July 6, July 13, July 20... basically I call every 7 days asking about my voice terminal, each time they tell me it's coming next week. I was getting pretty mad at this point, as they are charging me full price ($39) for internet and phone, when I could be paying them $29 for internet only, it's only $10 difference but still.. I should be recieving the service I'm currently paying for.

Technically, they advertise on their website http://www.cia.com that it's free internet if I order a phone line for $39 a month, I technically shouldn't need to pay anything since I still don't have a phone line.

July 26, 2006 - FINALLY recieved my voice terminal, however no UPS was included as per the instructions they send out.. I sent them an email notifying them and they tell me it will be shipped at a future date, no eta.

So all in all, it took 2 months to get my service setup, and I already had cable internet service previously with Shaw. The phone service seems decent, there seems to be a "blip" of noise at the beginning of calls but it's so quick it's not really a bother, most probably won't even notice it.

My main problem now is that it doesn't work! My phone terminal keeps crashing, my guess is because it can't deal with the amount of traffic I use. This takes down my whole internet connection, it's been happening about 2 to 3 times a day since I setup the voice terminal.

My guess is if I can get the voice terminal working behind the router, it may prevent this problem from occuring, but I am so far unable to do so as reported by others... I've tried dmz, portforwarding and even changing the mac address on my internet facing port to the same as my VT.

I started to do some googling to see if I could find a way to fix this problem and found that other have requested a 2nd ip address for the voice terminal to fix this. I call and talked to a tech and they confirm the same thing, so they put in request for a 2nd ip address now and hopefully that will work for me.

[Aug 5th Update]

It's now Aug 5th, I still do not have a working phone. I requested an 2nd ip address for phone terminal, it's been 8 days, still no response... I called earlier and I was told it would be at least another 3 days minimum because it's a long weekend. The person said they will call me. It's now been Well over 2 months since the beginning, and I still have no working phone service... at least not when I'm using the computers.

This may as well be called highspeed dialup, as I can't use the phone and the computers at the same time (at least with any reliabllity). Customer service with this company is extremely poor, you sure get what you pay for.

[Aug 9th Update]

I was told I would receive a call back, nothing today. No response to 2 emails I've sent them over a week ago now. Getting sick and tired of this, submitting a complaint to their local BBB.

[Aug 11 Update]

I called them again asking about my IP address, the tech i spoke with told me it was up and to try it out. I hung up and tested it. They did not provision my cable modem for 2 ip addresses. I tried multiple devices not just my router and ATA, but other devices, laptop and desktops.... I was not able to get more than 1 ip simulatenously. I used tcpdump to watch the traffic on the segment, and concluded I was only given 1 address. Either they don't know what they are doing or he flat out lied to me.

[Aug 14]
I called them back a day later after my weekend of of testing, and again after a 35 min way, I finally got a hold of someone who went through a bunch of useless tests which involved rebooting laptops, a router and ATA all in various orders and various configurations with my hub. Although some of his tests were valid and I did them on the phone with him while he did his tests from his side, I knew it was pointless. In the end he said he would request another IP address from Shaw

[Aug 16]

I missed a call on my cell phone but recieved a voicemail from cia, a rep told me that I now have been given a 3rd IP address. Strangely enough I recieved my UPS today... all this shortly after my BBB complaint. I seems you need to call the BBB in order to get things done with this company.

I tested my equipment, sure enough I can request 2 ip addresses from their dhcp servers now. Not a 3rd one like they said I've been assigned.

So this appears to be the end of my setup procedures with this company. I only put up with this because I don't have a need for a land line, I've never had one, only our cell phones. If i had a need for a landline or for reliable service, I would NOT recommend this company. If you don't really care how long it takes to get setup and want a cheap phone/internet combo package, then cia i supppose is for you.

Post a comment

(If you haven't left a comment here before, you may need to be approved by the site owner before your comment will appear. Until then, it won't appear on the entry. Thanks for waiting.)